You are here

ForwardSM sending problem

12 posts / 0 new
Last post
firask
ForwardSM sending problem

Dear all,

i'am trying to send MAP-MT-FORWARD-SHORT-MESSAGE-REQ or even MAP-FORWARD-SHORT-MESSAGE-REQ but there is no response is received at all from the MSC,
i think the problem is in:

MAPPN_sm_rp_ui ( user information ) : could any one help me with the format of this parameter what components should it be filled in it with which values ( please advice a document for it if there any ).

OR

should i send SRI before it. the case that i sent the SRI then i took the imsi from it and put it in the ForwardSM message but not directly, ( i took the imsi and create another message for forwardSM and put the imsi in it and send it ). is there a scenario that i should go through to receive a response...

OR

any other idea why there is no response from the MSC what advanced documents that could help me, or if there's any success forwardSM message trace that i could compare to my message.

Edited by: admin on 05/16/2010 - 04:32
pramod
Re: ForwardSM sending problem

Hi

Go through this doc  3GPP TS 23040 V6.8.1  for filling User Info param...

There lots of scenarios wher MSC cant send the response if the problem still exists
try to send the full trace of ur appln so that i can help..

firask
Re: ForwardSM sending problem

Thanx pramod for replying :)
could you give me the most known scenarios where MSC cant send the response to check it,  please ?
i will check the document you advised for, meanwhile i hope if any one could help me more in it .

Thanks again pramod  ;)

dineshonss7
Re: ForwardSM sending problem

Your smsc should send SRI_SM first , so that you will know the msc id in SRI_SM_RSP of the destination number to which you have to send the Forward SM.

firask
Re: ForwardSM sending problem

first thanks for replying
well , what i do that i sent the SRI and get the imsi from it's response.
and create another ForwardSM message and put the received imsi in it. and send it.
maybe i have a problem in filling it correctly in the forwardSM.

any suggestions???

Thanx again dineshonss7

pramod
Re: ForwardSM sending problem

While forming MT-ForwardSM(other Forward SM)
check for calling ,called party addresses wher called party addr should be the MSC addr which u got from the SRI-SM response(IMSI,MSC Addr),calling party should be ur SMSC addr.

regards
pramod

firask
Re: ForwardSM sending problem

well I suspected in the destination address but i think i put it right :s.

my message is as follows:

03 MAP-FORWARD-SHORT-MESSAGE-REQ

0e0101  MAPPN_invoke_id

1709040791 -destination address(MSISDN Or IMSI?)-    MAPPN_sm_rp_da

1809040791-Originating address(MSISDN)-    MAPPN_sm_rp_oa

1912010b0a91-destination address(MSISDN)- 0000ff04d4f29c0e00  MAPPN_sm_rp_ui

please if you found any problem in it or any potential errors in my message to reply ASAP.

best regards.

Thanks in Advance :)

firask
Re: ForwardSM sending problem

No suggestions?  ???

:( Help :'( Help :( Help :'(

pramod
Re: ForwardSM sending problem

Hi
In MT-FSM
SM-RP-DA should be IMSI (I dont think ur filling IMSI it should be 15 digits)
SM-RP-OA is Orig-MSISDN and  in User Info fill the Dest MSIDN, and also chek
ur SCCP portion for calling, called party GT addresses..

regards
pramod

firask
Re: ForwardSM sending problem

pramod :),

i changed my number to 15 digit IMSI,
please clarify to me SCCP portion and called party GT addresses..

thanks for replying  ;)

pramod
Re: ForwardSM sending problem

Hi
called party GT addr should be the MSC addr which u got from the SRI-SM response(IMSI,MSC Addr),calling party GT should be ur SMSC addr.

regards
pramod

firask
Re: ForwardSM sending problem

Thanks pramod for your prompt response i really appreciate it.

i put the calling party GT: I send it as follows,

0x13 Routing on global title.

0x_ _ _ _  my point code Point Code

0x08 To MSC
0x00 Translation Type
0x12 numbering plan , encoding scheme
0x04

then my calling party GT