You are here

MAP issue...

14 posts / 0 new
Last post
MAP issue...

Hi all,

I am facing strange problem. I am send some service mesg to hlr and getting the error mesg "no response from peer" for only once circle...  ( although i am able to open the dialog.... ).  For all other circle except this i am getting correct response...

can anybody tell me the posible reason of this error...?

for specific case... i m sending SRI-SM service mesg..


Edited by: admin on 05/16/2010 - 04:31
Re: MAP issue...

HI Vipul,

Generally  "no response from peer" is given by you local TCAP, whenever there is no response from the
remote end in the specified time out period.  ( I think this is specific message is given by Intel stacks where
as others give back error message like "time out" or something similar).

But as you are saying you  are able to open dialog, it looks like a rare case. Are you sure the MAP-Open responce
is from the remote end?

Looks like you are using Intel stack, Is it possible for you to enable MAP Trace and give the request and
response traces.. It may help to analise the issue.


PS: In case you solved it already, please post your experience here.

Re: MAP issue...

SRI-SM, It is used to query the HLR for Service MSC and IMSI of the subscriber. I need clear picture to solve your problem.

1) Are you querying the local subscriber ? or other operator's
2) What is the Hardware and Stack (Including Versions) you are using?
3) MAP Analyser Traces if you have

you said that it is working fine for some circles but not for a particular circle. If that is the case The Switch persons can help you in tracing your message why it is rejecting. (If your message reached to their HLR)

if it doesn't reach the proper destination then Check your translation Tables under SCCP. (Some times SCCP may translate the Numbers, and for particular Circle series may be translating to some thing else). I need more info to solve it.

Re: MAP issue...

firstly i will give the query of Sanketh :

yes i m using the intel stack, and surely i am able to open the dialog. i am sending you portion of trace:

sri-sm trace which creating problem:

S7L:I0000 T 0000d1bf M tc7e2 i1b64 f1d d15 s00 p01010d13c226060012041989069773150b09060704000001001402030b120800120419892999990200
S7L:I0000 T 0000d1bf M tc7e0 i1b64 f1d d15 s00 p010e01010f07911989069773151001011107911989295091412d020a0000
S7L:I0000 T 0000d1bf M tc7e2 i1b64 f1d d15 s00 p0500
S7L:I0000 T 0000d223 M t87e3 i1b64 f15 d1d s00 p8205010000
S7L:I0000 T 0000d223 M t87e1 i1b64 f15 d1d s00 p820e010116010800

sri-sm trace which is working fine:

S7L:I0000 T 0000c978 M tc7e2 i1b63 f1d d15 s00 p01010d13c226060012041989298682890b09060704000001001402030b120800120419892999990200
S7L:I0000 T 0000c978 M tc7e0 i1b63 f1d d15 s00 p010e01010f07911989298682891001011107911989295091412d020a0000
S7L:I0000 T 0000c978 M tc7e2 i1b63 f1d d15 s00 p0500
S7L:I0000 T 0000c979 M t87e3 i1b63 f15 d1d s00
p820501000b09060704000001001402010d13a80f08001204198929999902030d13c22606001204198929801100 00
S7L:I0000 T 0000c979 M t87e1 i1b63 f15 d1d s00 p820e0101120804949202059259f713079119892999991000
S7L:I0000 T 0000c979 M t87e3 i1b63 f15 d1d s00 p0400

i hope now u will able to figure out problem...

now query by ovlnmurty:

i am querying same operator but of other circle,infact a specific circle ( although i am able to make such query for all circle of other operator)
i am using intel stack it is septel pci
trace is given above

i will explore the point u mentioned in ur reply...

I have given the required detail.. and hoping the positive result...


unknown (not verified)
Re: MAP issue...

Hi Vipul,

Depending on this log:
S7L:I0000 T 0000d223 M t87e3 i1b64 f15 d1d s00 p8205010000
S7L:I0000 T 0000d223 M t87e1 i1b64 f15 d1d s00 p820e010116010800

I think you are not getting any response from the remote HLR. It is the response given by your local
MAP provider when the time out occurs.
In my openion, talking to the telco is the best way to sort this out.

Re: MAP issue...

hi all

i just want to modified information which i gave in last reply.. " i am not able to open dialog with remote end " i am getting confirmation from immediate node..
so now it seems that problem is related to SCCP routing... may be from my end or from operator end...

i would like further input from you guys to solve this problem...
ovlnmurty u have been talking about translation under sccp.. can u give some more info about it?


Re: MAP issue...

Hi Vipul,

Could you find out whats the real issue behind it?
Whats the progress?


Re: MAP issue...

Hi Vipul,
It seems to me more like a problem with the SCCP routing at the immediate node and/or at the down the line STPs.
You can Set the Parameter MSG_Handling in the SCCP layer to "Return Message on Error (8)" so as to receive a UDTS back from the node which fails to route the message to the desired destination.
This will help you identify the node and make the appropriate changes in the GT.
Hope this helps.
-- Ather

Sunil Kumar
Re: MAP issue...

Hi there,

ATHER's point is good.

If you have a Protocal Analyzers with the NOC Staffs then ask them to check the MESSAGE flow at your immediate gateway (I belive it will be a MSC).
If you get the query in from your System to MSC and out from that MSC towards HLR and no response from the other end then u have to do the same at the remote end.This way u can get the source wher the rejecteion happens can be identified.




S.Sunil Kumar

Re: MAP issue...


Which series is giving the problem ?

As other members have suggested the problem may be mainly due to SCCP routing but there could be another issue too.

Just type in following -
Series with no  issue :
Series with issue :


Re: MAP issue...

SRI_SM are routed on Global Title of the target MSISDN, not the Node address of the home HLR. The GT will take it to the HLR based on the SSN, which should be 6. The HLR may not respond if there is no route built in the home MSC to return this traffic to your node, or in the SCCP Provider Network. If this is the case, there will be no UDTS sent back. UDTS messages are usually sent when there is no GT loaded for the Called Party.

If you have some examples of numbers that you could share (CC and NDC info, nothing too specific), That might help.


Re: MAP issue...

i can't ,give you any help ,i'm still in the beginning of studing signalling.
but i would like ,to ask some usful links ,or documentaion concerning protocol MAP and its several versions if possible.
thank you very much for your help.

Re: MAP issue...

I am also facing the Same Error from the Signalling Gateway.. Seems there is no response for the SRI from the MSC...,

Hi ovlnmurty
How to take the MAP trace .. can you help.

hi vipul

it clearly says that u r not getting SRI-SM response for the No ,

if it is same ur HLR,check the SMSC GT in HLR.

See wher u r terminating the GT .

sending Correct SSN are NOT.

if possible give some Example with MSISDn's